libcggl.so fehlt

Du hast 1 neue Nachrichten seit deinem letzten Besuch.

Hallo zusammen,

Eben habe ich probiert, mir Plane Shift zu installieren, aber leider funktioniert es nicht so, wie erwartet. Beim Start via Terminal meldet es, libcggl.so fehle. Tatsächlich existiert eine solche Datei, ich kann sie aber nicht öffnen, da sie offenbar binär vorliegt.

Eine Googlerecherche zeigt mir, dass ich nciht der erste mit diesem Problem bin, aber irgendwie scheint es keine Lösung zu geben. Kann mir jemand weiterhelfen?

Merci!

Beste Grüsse

aeronaut

Hallo, kannst du mal die

Hallo,

kannst du mal die letzten sagen wir 30 Zeilen posten, was der Client so sagt?
Darüber hinaus wäre es ganz interessant, wenn du ev. deine "psclient.cfg" und "pslauch.cfg" posten oder verlinken könntest (beide im Installationsverzeichnis). Ich glaube nämlich, dass wir dann zeigen können, wie du die Dateien so verändern kannst, dass der Client läuft. In Kürze Vorweg: Im Grunde Suchen&Ersetzen von "openal" mit "null"

Sen


Bild von Tereay

Heya, schau mal ob es fuer

Heya, schau mal ob es fuer dein OS (Debian/Suse/Ubuntu....?)
ein update fuer die "libopenal-dev" und "libopenal1" gibt.
Ansonsten hilft auch selber bauen.


libCgGL ist ein Teil vom

libCgGL ist ein Teil vom nvidia-cg-toolkit, sollte eigentlich nichts mit openAL zu tun haben.

Quote:

$ equery b /opt/nvidia-cg-toolkit/lib/libCgGL.so
* Searching for /opt/nvidia-cg-toolkit/lib/libCgGL.so ...
media-gfx/nvidia-cg-toolkit-2.1.0017 (/opt/nvidia-cg-toolkit/lib/libCgGL.so)

Soweit ich weiß wird momentan das CG-toolkit in version 2.2 für PS benötigt, aber eigentlich nur wenn man den client selber compiliert. Die Binary Version bringt die Bibliothek bereits in Unterverzeichniss "libs" mit daher nehme ich eher an das der OP das Spiel mit "./psclient.bin" und nicht mit dem Script "psclient" welches den korrekten LD_LIBARY_PATH setzt gestartet hat. Also vielleicht mal versuchen das Spiel mit "./psclient" zu starten.